Jump to content

Pre-release 5: first impresions


Recommended Posts

-Removing "follow camera" and "sunlight range" breaks backwards compatibility. I used that a lot. Sometimes you use a schematic really far away from the initial point (sun point) and the shadows are casted in a way you don't like. Sometimes you just don't care if the shadows aren't accurate in relation to where the sun is at, what matters is that the scene looks good. Maybe give us an option to mvoe where the sun is at or something. But follow camera was good enough for me.

Also, we don't have now control over sunlight range, so it's now some unknown value and distant shadows are not rendered.  Sometimes it's worth the decrease in quality to get distant shadows rendered because the objects on the scene are far enough that it doesn't matter. For instance, a flying spaceship, or something far away from the Camera, that looks better when wasting a shadow, but now it doesn't. Bring back these options.

-Cameras attached to surfaces are not loading. I loaded my previous project, which used a surface that used a Camera as a texture to simulate a screen on a computer, it's now just white because the Camera is not there.

-Loops removed. Not sure why? If I want to quickly make an object do 12 spins, you would just add 12 instead of having to calculate 360x12. I didn't use this much but again, why remove control and options from animators?

-There's some sort of bug where textures show a grid and skins are blurred out:

tex1.png

tex2.png

Sometimes it disappears, you move around, it disapears, but it shows up again and then disappears and so on.

-Changes on the new render makes everything too bright, im trying to adjust things to make it look as it was before but something looks off.

-The alpha remains a problem throught the depth of field blur. I've tried default, hashed and blended, this is how it looks:

minedof.png

-I noticed that the new "Brightness" setting now called "Emisive" which goes from 0 to infinite%?? does not just add brightness to the texture, it modifies it and it's screwing up my light textures. For instance, I have this light .png file, first thing I do is always set brightness to 100%. This is how it looked like:

brightness-1.png

Now this is how it looks like if I open the project on the new version:

brightness-2.png

-"Subsurface scattering" is confusing. I used to place a point light inside something that I wanted to be a source of light, like a block of glowstone, and then I just would click on "bleed light", now im not sure what im doing. I've moved the radius and color option but im not sure what it's doing.

I see improvements on the GUI, being able to search by name on the timeline is really useful, but some stuff is confusing, I have to look around to find what I was able to find easily before.

Also, having to double click to select all keyframes is annoying. Not sure why the button was deleted. Same for reseting values on GUI boxes, right click was useful to quickly do this. It's things you do often. We need fast buttons or at least shortcuts.
And im trying to find the grid size for stuff, it's gone. Why did you move this from being next to what you are trying to modify? It's like, I want to move in increments of 16, then why not leave this where it was? I have to find this now somewhere else named "Viewport"? according to the changelog, which I cannot find. The "Snap to XYZ values to a grid" button was useful being next to what you want to move.

And as far as bugs and visual glitches beside the ones I described:
 

 

There's also some missing features, which would be insanely useful, such as this:

And finally i've noticed render times are now slower.

rendertime.png

And this is just a piece of wool with a point light and Steve. 8 minutes? it took seconds with the previous version.

Rendering a 20 minute animation will probably be like rendering a Disney Pixar movie at this rate. Im assuming it's slower due increase shadow accuracy and whatnot but there's nothing to speed it up? It's probably going to take days to render a full animation now.

I've disabled Indirect Lightning, Reflections, Gamma Control, and it goes a bit faster, but still 4 minutes vs what took seconds.

Someone mentioned "Samples" being lowered,makes it go faster and it does, but im wondering, what was the previous amount of Samples used in the previous versions where you wouldn't be able to choose? Those are my settings for previous version:

rendersettings.png

Which settings do I select on the new one to make it go as fast the previous one but with the same quality?

Or it's always going to be slower now no matter what?

Edited by moniker
Link to post
Share on other sites

Follow camera / Sunlight range: These features were removed with the introduction of Cascading Shadow Maps and directional lighting to provide correct shadows casting across the entire scene. These options won't be returning.

image.thumb.png.888536606a2bedd21e07e08a1970a450.png

On 11/21/2022 at 3:02 PM, moniker said:

-Cameras attached to surfaces are not loading. I loaded my previous project, which used a surface that used a Camera as a texture to simulate a screen on a computer, it's now just white because the Camera is not there.

Most likely a bug.

On 11/21/2022 at 3:02 PM, moniker said:

-Loops removed. Not sure why? If I want to quickly make an object do 12 spins, you would just add 12 instead of having to calculate 360x12. I didn't use this much but again, why remove control and options from animators?

Math inputs are now supported, type "360 * [number here]" and Mine-imator will calculate it.

On 11/21/2022 at 3:02 PM, moniker said:

There's some sort of bug where textures show a grid and skins are blurred out

- snip -

Sometimes it disappears, you move around, it disapears, but it shows up again and then disappears and so on.

Are your graphics drivers up to date? Download to affected project or way to recreate would help us.

On 11/21/2022 at 3:02 PM, moniker said:

-Changes on the new render makes everything too bright, im trying to adjust things to make it look as it was before but something looks off.

Ambient lighting now behaves like a proper light source instead of "mixing" into dark areas.

On 11/21/2022 at 3:02 PM, moniker said:

-The alpha remains a problem throught the depth of field blur. I've tried default, hashed and blended, this is how it looks:

Does raising the sample count improve this? Hashing is the only solution Mine-imator can really provide given how it renders it's scene and it requires a decent amount of samples to good. (Can access "Samples" by going into "Project settings", changing "Render settings" to "Custom" and a new tab will appear.)

On 11/21/2022 at 3:02 PM, moniker said:

-I noticed that the new "Brightness" setting now called "Emisive" which goes from 0 to infinite%?? does not just add brightness to the texture, it modifies it and it's screwing up my light textures. For instance, I have this light .png file, first thing I do is always set brightness to 100%. This is how it looked like:

Bug, will look into it for Pre-release 6.

On 11/21/2022 at 3:02 PM, moniker said:

-"Subsurface scattering" is confusing. I used to place a point light inside something that I wanted to be a source of light, like a block of glowstone, and then I just would click on "bleed light", now im not sure what im doing. I've moved the radius and color option but im not sure what it's doing.

"Subsurface" determines the distance a light source can penetrate an object, the RGB fields determine the strength per channel to replicate more complex materials.image.thumb.png.131339f5ca497e3039dfd90871ec87ee.png

To add, "Bleed light" was also removed due it using tricks that didn't adapt to other lighting changes(it was a super hacky effect to begin with) and the removal of "Shadow blur size"/"Shadow blur quality" as lights now have their own "Size" setting to determine softness.

On 11/21/2022 at 3:02 PM, moniker said:

Also, having to double click to select all keyframes is annoying. Not sure why the button was deleted. Same for reseting values on GUI boxes, right click was useful to quickly do this. It's things you do often. We need fast buttons or at least shortcuts.

"Shift + Right click" is now used for fast resetting values.

 

Finally, we're looking into optimizing rendering for Pre-release 6, for faster render times I'd recommend lowering samples down to ~24 and disabling "Indirect lighting" and "Reflections" as these rely on a form of raytracing and are most intense on rendering.

Link to post
Share on other sites

On 11/21/2022 at 2:02 PM, moniker said:

And im trying to find the grid size for stuff, it's gone. Why did you move this from being next to what you are trying to modify? It's like, I want to move in increments of 16, then why not leave this where it was? I have to find this now somewhere else named "Viewport"? according to the changelog, which I cannot find. The "Snap to XYZ values to a grid" button was useful being next to what you want to move.

Top right of the viewport. I find it much handier to have these here as I don't have to select what I want to move to activate snapping. In fact, it's got a keyboard shortcut (F) so I don't even need to click anywhere. Big improvement if you ask me.

image.png

Link to post
Share on other sites

@Nimi The Samples was set at 64 on these screenshots. So im assuming we are stuck with the DOF+alpha problem not being solved.

What was the previous "Samples" value on the former versions where you couldn't choose it? 24 is still pretty slow, even with no reflections and ambient lightning disabled. Im assuming things will be slower now because shadows are more accurate?

Also, with removing sunlight range, how far is the range now then? is it "infinite"? Like I said, if I want shadows on a really far away object like a spaceship or something, I used the highest sunlight range possible, now im not sure how far into the scene shadows are casted.

Did you look at these 2 bugs?

The first one seems to be fixed now, clips seem to be at 30fps again, but the second one is still happening.

 

And another bug i've just realized is that if you set the Environment ground as the water texture it's fixed, lacks the animation.

Edited by moniker
Link to post
Share on other sites

On 11/22/2022 at 7:35 AM, Dr. Nexil said:

Top right of the viewport. I find it much handier to have these here as I don't have to select what I want to move to activate snapping. In fact, it's got a keyboard shortcut (F) so I don't even need to click anywhere. Big improvement if you ask me.

image.png

Im going to test around before I decide if I really miss the old GUI enough to keep using the old version.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    No registered users viewing this page.

  • Create New...