Jump to content

Dev update #20: 2020 wrap-up and 1.3 progress update


Recommended Posts

"Frustum culling"

So we will finally be able to work with smooth FPS while having loaded big schematics and cubes/objects? As it stands Mineimator FPS slow downs so easy after you add an schematic, some cubes and objects for the finishing touches + have 2 or 3 minutes of keyframes. Also having the Camera window and "Toggle controls, wireframes and highighs in this view" enabled makes it worse.

 

Btw I have found a strange Memory leak:

 

Something on that rig causes Mineimator to consume an infinite amount of RAM (it keeps going up until it collapses). Tested on both 1.2.6 and 1.2.7.

Edited by moniker
Link to post
Share on other sites
4 hours ago, moniker said:

"Frustum culling"

So we will finally be able to work with smooth FPS while having loaded big schematics and cubes/objects? As it stands Mineimator FPS slow downs so easy after you add an schematic, some cubes and objects for the finishing touches + have 2 or 3 minutes of keyframes. Also having the Camera window and "Toggle controls, wireframes and highighs in this view" enabled makes it worse.

 

Btw I have found a strange Memory leak:

 

Something on that rig causes Mineimator to consume an infinite amount of RAM (it keeps going up until it collapses). Tested on both 1.2.6 and 1.2.7.

If it’s a rig causing it then I wouldn’t entirely say the software itself is the problem.

Link to post
Share on other sites
6 hours ago, moniker said:

The memory leak is happening inside Mine-imator.exe, hard to argue it isn't the software.

It came from the software because it was being overdone by the rig!

Link to post
Share on other sites

hey nimi before you release this in the summer time, i want you to add this feature in the resolution..

"QLED 8K" this feature will make renders look fantastic in 8K resolution, people has been requesting this for almost 2 years, this feature might be perfect for the 1.3.0 lighting and graphics

Link to post
Share on other sites
1 hour ago, Aric Horn said:

hey nimi before you release this in the summer time, i want you to add this feature in the resolution..

"QLED 8K" this feature will make renders look fantastic in 8K resolution, people has been requesting this for almost 2 years, this feature might be perfect for the 1.3.0 lighting and graphics

Due to the new graphical features, exporting 4k renders and animations will be difficult for the program.(Depending on computer specs and what settings are enabled.) I can't imagine Mine-imator handling 8k exporting due to the memory requirements of the resolution. Besides, you can set a custom resolution if you need or want to try 8k exporting.

Link to post
Share on other sites
7 hours ago, Nimi said:

Due to the new graphical features, exporting 4k renders and animations will be difficult for the program.(Depending on computer specs and what settings are enabled.) I can't imagine Mine-imator handling 8k exporting due to the memory requirements of the resolution. Besides, you can set a custom resolution if you need or want to try 8k exporting.

in short we can just use the custom resolution on the camera to make it 8k. Right?

Link to post
Share on other sites
On 1/5/2021 at 1:10 AM, CRAZYKOKEBROZ said:

It came from the software because it was being overdone by the rig!

The rig is not some super complex thing, it's just a medkit with some stuff inside. There's clearly something wrong going on in there.

Link to post
Share on other sites
4 hours ago, moniker said:

The rig is not some super complex thing, it's just a medkit with some stuff inside. There's clearly something wrong going on in there.

Because there is a component (or two) within that medkit that is consuming all of the data. This causes Mine-Imator to act slow and then crash. There is literally nothing wrong with the software.

Link to post
Share on other sites
On 1/8/2021 at 12:54 AM, CRAZYKOKEBROZ said:

Because there is a component (or two) within that medkit that is consuming all of the data. This causes Mine-Imator to act slow and then crash. There is literally nothing wrong with the software.

This is not how software development work. You have to put barriers in your software so memory leaks never happen.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    No registered users viewing this page.

  • Create New...