Jump to content
Findrek

Can't change minecraft version

Recommended Posts

after downloading 1.2.4 with the newest version too i wanted to go back to minecraft 1.13 to continue my projects but i couldn't after many tries.

Dk5cls7.png

i set this to 1.13.1 and restarted the program but every time i opened it again it reverted back to 1.14.

vpqCjjD.png65NBWt9.png

i even checked in the settings and after applying the version change it appears as 1.13, but the moment i open an existing project or create a new one the file changes to 1.14 again, and not even restarting my PC solved the issue.

is there any way to properly change the game versions or at least uninstall 1.14 without it causing any problems?

Edited by Findrek

Share this post


Link to post
Share on other sites
1 hour ago, jakubg1 said:

Probably there's no backward compatibility for earlier Minecraft versions.

However, you can convert the 1.13.1 world to a 1.14.1 one :)

That makes no sense- why would they have that version if they don’t have backwards compatibility?

 

Try deleting ‘1.14.1.zip’ and ‘1.14.1.midata’ in the data folder, then go to your roaming folder- (the same one with Minecraft in it) and look for mine-imator, when there delete the ‘Minecraft_unzip’ folder and reopen mine-imator. Haven’t tested this but worst case it just gives you a prompt to redownload 1.14.1.

Share this post


Link to post
Share on other sites
3 hours ago, Jake_28 said:

That makes no sense- why would they have that version if they don’t have backwards compatibility?

 

Try deleting ‘1.14.1.zip’ and ‘1.14.1.midata’ in the data folder, then go to your roaming folder- (the same one with Minecraft in it) and look for mine-imator, when there delete the ‘Minecraft_unzip’ folder and reopen mine-imator. Haven’t tested this but worst case it just gives you a prompt to redownload 1.14.1.

i've tried and it didn't work either, deleting those and opening the program again gave this error

RNbqbRp.png

then i reinstalled mine-imator but it opened regularly back to 1.14 like before.

i looked into the log and found this bit

fkv0odm.png

maybe the format number has to be changed in the settings?

Share this post


Link to post
Share on other sites
27 minutes ago, Findrek said:

-snip

i looked into the log and found this bit

fkv0odm.png

maybe the format number has to be changed in the settings?

I think I know what’s happening- It allows compatibility between Minecraft versions but the midata has to be written in the latest format, probably to avoid corruption. You can go into 1.13.1.midata and change the format number to 5, but I would probably recommend backing up your projects first. Once you change the format to 5 change to the version like normal and restart like normal and it should work.

Share this post


Link to post
Share on other sites
10 hours ago, Jake_28 said:

I think I know what’s happening- It allows compatibility between Minecraft versions but the midata has to be written in the latest format, probably to avoid corruption. You can go into 1.13.1.midata and change the format number to 5, but I would probably recommend backing up your projects first. Once you change the format to 5 change to the version like normal and restart like normal and it should work.

for a split moment it did work and started downloading the 1.13 textures!

rN2O3RK.png

Fqh7Am5.png

now the problem is it doesn't recognize the particle textures...

 

Share this post


Link to post
Share on other sites
52 minutes ago, Findrek said:

for a split moment it did work and started downloading the 1.13 textures!

rN2O3RK.png

Fqh7Am5.png

now the problem is it doesn't recognize the particle textures...

 

I forgot in 1.14 they changed how the particle and painting textures are stored...

try unzipping the 1.14 zip and 1.13 zip, and copy the particles folder from 1.14 / assets / ?? to the same place but swap 1.14 for 1.13, then zip the 1.13 assets back into the zip and try again? (make backup first ofc) 

(dunno if paintings matter)

 

edit: and you also probably have to add the textures in the midata, just open the 1.14 midata in a text editor and look for “particle_textures”: { or something like that, and select from that line to the next ‘}’ and copy it to the 1.13.1 midata- probably at the end of the file right before the last ‘}’ or wherever you found it in the 1.14 midata

 

edit 2: oh and delete Minecraft_unzip in the roaming/mine-imator folder again

Edited by Jake_28

Share this post


Link to post
Share on other sites
1 hour ago, Jake_28 said:

I forgot in 1.14 they changed how the particle and painting textures are stored... 

try unzipping the 1.14 zip and 1.13 zip, and copy the particles folder from 1.14 / assets / ?? to the same place but swap 1.14 for 1.13, then zip the 1.13 assets back into the zip and try again? (make backup first ofc) 

(dunno if paintings matter)

 

edit: and you also probably have to add the textures in the midata, just open the 1.14 midata in a text editor and look for “particle_textures”: { or something like that, and select from that line to the next ‘}’ and copy it to the 1.13.1 midata- probably at the end of the file right before the last ‘}’ or wherever you found it in the 1.14 midata

 

edit 2: oh and delete Minecraft_unzip in the roaming/mine-imator folder again

it finally worked! thanks a lot!

after that i ran into a couple more issues where it didn't detect the banner pattern textures or pattern list, for anyone else running into this problem i copied too the lines where they're mentioned in the 1.14 midata to the 1.13 one removing the last pattern of the globe.

now just hoping for a future mine-imator version or at least a patch it can convert earlier versions automatically without this much trouble.

Share this post


Link to post
Share on other sites
3 hours ago, __Pixely__ said:

I'm having the same problem but its not in minecraft versions its in the  kens mod i cant get it to be enabled it just resets can anyone help? :(

It's not a mod, it's a facial rig if I guess correctly. Can you explain the problem more?

Share this post


Link to post
Share on other sites

i did it in a post but it is no longer available for some reason but i can tell you the problemo! so basically, I wanted to make an animation with kens model with characters in the umm toolbox its custom stuff so i wanted to use it and so i try then, i restart as it told me to then i open it up then its 1.14 again sadly i cant find my post one guy on the post said that he had had this problem and theres something wrong with my .midata file but i didn't know what to do with it then if you could explain in a reply that would be totally awesome! :D

Share this post


Link to post
Share on other sites
6 minutes ago, __Pixely__ said:

i did it in a post but it is no longer available for some reason but i can tell you the problemo! so basically, I wanted to make an animation with kens model with characters in the umm toolbox its custom stuff so i wanted to use it and so i try then, i restart as it told me to then i open it up then its 1.14 again sadly i cant find my post one guy on the post said that he had had this problem and theres something wrong with my .midata file but i didn't know what to do with it then if you could explain in a reply that would be totally awesome! :D

I think this problem doesn't appear just because you're importing KEN's rig, but MI seems to reset the version each time it's launched. I can't help you there, because I'm just fine with 1.14.4 resources. Sorry. 😕

Share this post


Link to post
Share on other sites
1 hour ago, __Pixely__ said:

oh ok then i just really wanna use it cos it has a new walkcycle

Can you post the .midata and the .zip files? I can look into it.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...